Údržba a kompatibilita s PHP

Nette je framework s mimořádně dlouhou dobou podpory jednotlivých vydání. Každá větěv je LTS (Long-Term Support Release) s podporou nejméně 2 roky.

Každá verze je aktivně udržována po období jednoho roku (nebo i déle) od počátečního stabilního vydání. Kritické a bezpečností chyby jsou opravovány po dva roky.

2013 2014 2015 2016 2017 2018 2019 2020 2021 2022 2023 2.0 2.1 2.2 2.3 2.4 3.0 3.1 Today: 29. 10. 2020 Active support Security fixes only End of life version Unreleased version

Kompatibilita s PHP

Kompatiblita platí vždy pro nejnovější vydání z každé řady.

series requires at least is compatible with
Nette 3.1 PHP 7.2 PHP 8.0
Nette 3.0 PHP 7.1 PHP 8.0
Nette 2.4 PHP 5.6 PHP 7.4
Nette 2.3 PHP 5.4 PHP 7.1
Nette 2.2 PHP 5.3 PHP 7.0
Nette 2.1 PHP 5.3 PHP 7.0
Nette 2.0 PHP 5.2 PHP 5.6
Nette 0.9 PHP 5.2 PHP 5.3
Nette 0.8 PHP 5.2 PHP 5.3
Nette 0.7 PHP 5.2 PHP 5.3
Vylepšit tuto stránku